Back to overview
Resolved

Networking unavailable

Mar 20, 2026 at 12:44pm UTC
Affected services
Phala Cloud API
Proof t16z
Phala PCCS
Prod3 Node
Prod5 Node
Prod7 Node
Prod9 Node
Use1 Node
Use2 Node
Use3 Node

Resolved
Mar 20, 2026 at 12:44pm UTC

We are currently experiencing networking issues affecting some nodes in US-West. Our team is actively investigating, and we will share updates as soon as possible. Thank you for your patience.